Resolved

Incident Report for Palmetto

Resolved

We think the impact from the issue is over.
Posted Mar 22, 2023 - 15:57 UTC

Monitoring

A Fix was implemented and we a re monitoring the situation.
Posted Mar 22, 2023 - 15:45 UTC