E-signature provider issue in progress

Incident Report for Palmetto

Resolved

We think the impact from the issue is over.
Posted May 15, 2023 - 18:54 UTC

Monitoring

We are experiencing a recovery with our e-signature provider and are currently monitoring.
Posted May 15, 2023 - 17:55 UTC

Update

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted May 15, 2023 - 17:05 UTC

Investigating

We are aware of an issue with our e-signature provider and are working with the provider on a resolution.
Posted May 15, 2023 - 16:58 UTC
This incident affected: Palmetto Alchemy (Alchemy Console, Alchemy Financing Services).