Issue in progress

Incident Report for Palmetto

Resolved

AWS services have been restored and financial services are fully operational.
Posted Sep 28, 2022 - 21:10 UTC

Monitoring

We are continuing to monitor financial services while AWS services are being restored.
Posted Sep 28, 2022 - 20:55 UTC

Identified

Due to an AWS outage, some of our financial services may be experiencing issues.
Posted Sep 28, 2022 - 20:21 UTC
This incident affected: Palmetto Alchemy (Alchemy Financing Services).