Twilio Flex Outage

Incident Report for Palmetto

Resolved

Issue resolved
Posted May 19, 2023 - 02:12 UTC

Monitoring

Twilio Flex, is experiencing an outage. We are closely monitoring the situation. We will post updates when we know more. Thank you for your patience.
Posted May 18, 2023 - 23:52 UTC